RCE

· 소식
한국 시간 기준 2021년 10월 10일, Apache 재단에서 관리하는 Java 오픈 소스 로깅 라이브러리 "Log4j"에서 새로운 제로 데이 원격 실행 코드 취약점(Remote Code Execution, RCE)이 공개되었다. 버전 2.0-beta9부터 2.14.1까지의 Log4j 라이브러리를 사용하는 모든 Java 소프트웨어가 영향 대상이며, 영향을 받는 버전은 로그 메시지 및 매개변수에 사용되는 JNDI 기능이 공격자가 제어하는 LDAP 및 기타 JNDI 관련 엔드포인트로부터 보호되지 않는다. 로그 메시지 또는 로그 메시지 매개변수를 제어할 수 있는 공격자는 메시지 조회 대체 기능이 활성화된 경우 LDAP 서버에서 로드된 임의 코드를 실행할 수 있다. Apache 재단에서는 보안 취약점 문서를 ..
김도훈
'RCE' 태그의 글 목록